Install Guide

개요

전자정부 개발자 개발환경은 기본적으로 Windows 32 Bit 기반으로 제공되나 이 이외의 환경에서도 사용 가능하다.
Windows 32 Bit 이외의 환경에서 개발환경을 사용할 필요가 있을 경우 본 가이드를 참고하도록 한다.

설명

개발환경을 개별적으로 구성해야 할 필요가 있을 경우 환경에 맞는 eclipse를 다운로드 받아 다음의 순서에 맞게 설치하도록 한다.
설치 소프트웨어 간 dependency 정보가 있으므로 반드시 아래의 순서를 따르도록 한다.

* 주의 전자정부 개발자 개발환경은 Oracle Java상에서 기능이 정상적으로 동작합니다. 다른 java (Open JDK)에서는 일부 기능이 정상적으로 동작하지 않을 수 있습니다.
* 주의 설치가이드 플러그인 [자동설치/업데이트주소]는 최신버전을 다운로드 받을 수 있는 주소 입니다. 개발환경에 설치된 버전과의 차이가 있을 수 있습니다.
* 주의 설치가이드 플러그인 [자동설치/업데이트주소]는 해당 플러그인을 공식적으로 받을 수 있는 저작자의 배포 주소 입니다. 주소가 변경되거나 상황에 따라서 다운로드가 안될 수 있습니다.

설치가이드

  • Eclipse Neon(4.6) Packages 이용 시 설치가이드
소프트웨어버전자동설치/업데이트주소필수여부
Eclipse 4.6.3 http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/neon3 → Eclipse IDE for Java EE Developers 다운로드 필수
Spring Core 3.8.4 http://dist.springsource.com/release/TOOLS/update/e4.5 → Core / Spring IDE → Spring IDE Core 필수
UML2 Extension 5.2.3 http://download.eclipse.org/releases/neon → Modeling → UML2 Extender SDK 필수
Subversive SVN Connector 6.0.4 http://download.eclipse.org/technology/subversive/4.0/update-site/ → Subversion SVN Team Provider Plugin → Subversive SVN Team Provider(4.0.5) 설치
http://community.polarion.com/projects/subversive/download/eclipse/6.0/neon-site/ → Subversive SVN Connectors → Subversive SVN Connectors(6.0.4) 설치, SVNKit 1.8.14 Implementation(6.0.4) 설치
필수
eGovFrame 3.7.0 http://maven.egovframe.kr:8080/update_3.7/에서 필요 기능 설치 필수
JUnit 4.12 Eclipse에 JUnit이 내장되어 있으므로 별도 설치 필요 없음 필수
MyBatipse 1.1.0 http://dl.bintray.com/harawata/eclipse → MyBatipse → MyBatipse(1.1.0) 선택
PMD 4.0.14 https://dl.bintray.com/pmd/pmd-eclipse-plugin/updates/ → PMD for Eclipse 4 → PMD Plug-in (4.0.14) 설치 선택
FindBugs 3.0.1 http://findbugs.cs.umd.edu/eclipse 선택
Properties Editor 6.0.4 http://propedit.sourceforge.jp/eclipse/updates/ → PropertiesEditor 설치 선택
EclEmma 3.0.0 http://update.eclemma.org/ → EcliEmma → EclEmma Java Code Coverage 선택
Gradle 1.0.21 http://download.eclipse.org/buildship/updates/e45/releases/1.0 → Buildship: Eclipse Plug-ins for Gradle → Buildship: Eclipse Plug-ins for Gradle 선택
Developer Tools 23.0.7 http://rgladwell.github.com/m2e-android/updates/ → Developper Tools → 모두설치 안드로이드 개발 필수
Android Connector for M2E 1.4.0 http://rgladwell.github.com/m2e-android/updates/ → Android for Maven Eclipse → Android for Maven Eclipse 안드로이드 개발 필수
  • Eclipse Mars(4.5) Packages 이용 시 설치가이드
소프트웨어버전자동설치/업데이트주소필수여부
Eclipse 4.5 http://www.eclipse.org/downloads/packages/release/Mars/2 → Eclipse IDE for Java EE Developers 다운로드 필수
Spring Core 3.7.3 http://dist.springsource.com/release/TOOLS/update/e4.4/ → Core / Spring IDE → Spring IDE Core 필수
UML2 Extension 5.1.2 http://download.eclipse.org/releases/mars/ → Modeling → UML2 Extender SDK 필수
Subversive SVN Connector 6.0.1 http://download.eclipse.org/releases/mars/ → Collaboration → Subbersive SVN Team Provider(3.0.4) 설치
http://community.polarion.com/projects/subversive/download/eclipse/5.0/mars-site/ → Subversive SVN Connectors → Subversive SVN Connectors(5.0.3) 설치, SVNKit 1.8.12 Implementation(5.0.3) 설치
필수
eGovFrame 3.6.0 http://maven.egovframe.kr:8080/update_3.6/에서 필요 기능 설치 필수
JUnit 4.12 Eclipse에 JUnit이 내장되어 있으므로 별도 설치 필요 없음 필수
MyBatipse 1.0.23 http://dl.bintray.com/harawata/eclipse → MyBatipse → MyBatipse 선택
PMD 4.0.11 https://sourceforge.net/projects/pmd/files/pmd-eclipse/update-site/ → PMD for Eclipse 4 → PMD Plug-in 설치 선택
FindBugs 3.0.1 http://findbugs.cs.umd.edu/eclipse 선택
Properties Editor 6.0.4 http://propedit.sourceforge.jp/eclipse/updates/ → PropertiesEditor 설치 선택
EclEmma 2.3.3 http://update.eclemma.org/ → EcliEmma → EclEmma Java Code Coverage 선택
Gradle 1.0.21 http://download.eclipse.org/buildship/updates/e45/releases/1.0 → Buildship: Eclipse Plug-ins for Gradle → Buildship: Eclipse Plug-ins for Gradle 선택
Developer Tools 23.0.7 http://rgladwell.github.com/m2e-android/updates/ → Developper Tools → 모두설치 안드로이드 개발 필수
Android Connector for M2E 1.4.0 http://rgladwell.github.com/m2e-android/updates/ → Android for Maven Eclipse → Android for Maven Eclipse 안드로이드 개발 필수
  • Eclipse Luna(4.4) Packages 이용 시 설치가이드
소프트웨어버전자동설치/업데이트주소필수여부
Eclipse 4.4 http://www.eclipse.org/downloads/packages/release/luna/sr2 → Eclipse IDE for Java EE Developers 다운로드 필수
Spring Core 3.7.0 http://dist.springsource.com/release/TOOLS/update/e4.4/ → Core / Spring IDE → Spring IDE Core 필수
UML2 Extension 5.0.2 http://download.eclipse.org/releases/luna/ → Modeling → UML2 Extender SDK 필수
Subversive SVN Connector 2.0.4 http://download.eclipse.org/releases/luna/ → Collaboration → Subbersive SVN Team Provider 설치
http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/ → Subversive SVN Connectors → Subversive SVN Connectors 설치, SVNKit 1.8.7 Implementation 설치
필수
eGovFrame 3.5.1 http://maven.egovframe.kr:8080/update/에서 필요 기능 설치 필수
JUnit 4.11 Eclipse에 JUnit이 내장되어 있으므로 별도 설치 필요 없음 필수
MyBatipse 1.0.13 http://dl.bintray.com/harawata/eclipse → MyBatipse → MyBatipse 선택
PMD 4.0.7 https://sourceforge.net/projects/pmd/files/pmd-eclipse/update-site/ → PMD for Eclipse 4 → PMD Plug-in 설치 선택
FindBugs 3.0.1 http://findbugs.cs.umd.edu/eclipse 선택
Properties Editor 6.0.4 http://propedit.sourceforge.jp/eclipse/updates/ → PropertiesEditor 설치 선택
EclEmma 2.3.2 http://update.eclemma.org/ → EcliEmma → EclEmma Java Code Coverage 선택
Developer Tools 23.0.7 http://rgladwell.github.com/m2e-android/updates/ → Developper Tools → 모두설치 안드로이드 개발 필수
Android Connector for M2E 1.4.0 http://rgladwell.github.com/m2e-android/updates → Android for Maven Eclipse → Android for Maven Eclipse 안드로이드 개발 필수
  • Eclipse Kepler(4.3) Packages 이용 시 설치가이드
소프트웨어버전자동설치/업데이트주소필수여부
Eclipse 4.3 http://www.eclipse.org/downloads/packages/release/kepler/sr2 → Eclipse IDE for Java EE Developers 다운로드 필수
Spring Core 3.6.2 http://dist.springframework.org/release/IDE → Core / Spring IDE → Spring IDE Core 필수
UML2 Extension 4.1.2 http://download.eclipse.org/releases/kepler/ → Modeling → UML2 Extender SDK 필수
Subversive SVN Connector 2.0.1 http://download.eclipse.org/releases/luna/ → Collaboration → Subbersive SVN Team Provider 설치
http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/ → Subversive SVN Connectors → Subversive SVN Connectors 설치, SVNKit 1.8.6 Implementation 설치
필수
eGovFrame 3.1.0 표준프레임워크포탈 > 다운로드 > 개발환경 다운로드 URL에서 구현도구(Implementation Tool) 다운로드 후 설치
Help > Install New Software > Add클릭 > Archive선택하여 구현도구 파일 등록
필수
JUnit 4.11 Eclipse에 JUnit이 내장되어 있으므로 별도 설치 필요 없음 필수
MyBatipse 1.0.8 http://dl.bintray.com/harawata/eclipse → MyBatipse → MyBatipse 선택
PMD 4.0.4 https://sourceforge.net/projects/pmd/files/pmd-eclipse/update-site/ → PMD for Eclipse 4 → PMD Plug-in 설치 선택
FindBugs 2.0.2 http://findbugs.cs.umd.edu/eclipse 선택
Properties Editor 6.0.0 http://propedit.sourceforge.jp/eclipse/updates/ → PropertiesEditor 설치 선택
EclEmma 2.3.2 http://update.eclemma.org/ → EcliEmma → EclEmma Java Code Coverage 선택
Developer Tools 23.0 http://rgladwell.github.com/m2e-android/updates/ → Developper Tools → 모두설치 안드로이드 개발 필수
Android Connector for M2E 1.1.0 http://rgladwell.github.com/m2e-android/updates → Android for Maven Eclipse → Android for Maven Eclipse 안드로이드 개발 필수
  • Eclipse Juno(4.2) Packages 이용 시 설치가이드
소프트웨어버전자동설치/업데이트주소필수여부
Eclipse 4.2 http://www.eclipse.org/downloads/packages/release/juno/sr1 → Eclipse IDE for Java EE Developers 다운로드 필수
Maven(m2eclipse) 1.3.1
0.17.0
http://download.eclipse.org/m2e-wtp/releases/ → Maven Integration for Eclipse → m2e - Maven Integration for Eclipse / Maven Integration for WTP (Incubation) → m2e-wtp - Maven Integration for WTP (Incubation) 설치 필수
Spring Core 3.1.0 http://dist.springframework.org/release/IDE → Core / Spring IDE → Spring IDE Core 필수
UML2 Extension 4.0.2 http://download.eclipse.org/releases/juno/ → Modeling → UML2 Extender SDK 필수
Subversive SVN Connector 1.0.0 http://download.eclipse.org/releases/juno → Collaboration → Subversive SVN Team provider(Incubation) 설치
http://community.polarion.com/projects/subversive/download/eclipse/2.0/juno-site/ → Subversive SVN Connectors → Subversive SVN Connectors 설치
필수
eGovFrame 2.5.0 표준프레임워크포탈 > 다운로드 > 개발환경 다운로드 URL에서 구현도구(Implementation Tool) 다운로드 후 설치
Help > Install New Software > Add클릭 > Archive선택하여 구현도구 파일 등록
필수
JUnit 4.8.1 Eclipse에 JUnit이 내장되어 있으므로 별도 설치 필요 없음 필수
PMD 3.2.6 https://pmd.sourceforge.net/eclipse → PMD for Eclipse 3 설치 선택
FindBugs 2.0.2 http://findbugs.cs.umd.edu/eclipse 선택
Properties Editor 6.0.0 http://propedit.sourceforge.jp/eclipse/updates/ → PropertiesEditor 설치 선택
Developer Tools 22.3 https://dl-ssl.google.com/android/eclipse/ → Developper Tools 안드로이드 개발 필수
Android Connector for M2E 0.4.3 http://rgladwell.github.com/m2e-android/updates → Android Connector for M2E 안드로이드 개발 필수
  • Eclipse Indigo(3.7) Packages 이용 시 설치가이드
소프트웨어버전자동설치/업데이트주소필수여부
Eclipse 3.7 http://www.eclipse.org/downloads/packages/release/indigo/sr2 → Eclipse IDE for Java EE Developers 다운로드 필수
Maven(m2eclipse) 1.3.1
0.17.0
http://download.eclipse.org/m2e-wtp/releases/ → Maven Integration for Eclipse → m2e - Maven Integration for Eclipse / Maven Integration for WTP (Incubation) → m2e-wtp - Maven Integration for WTP (Incubation) 설치 필수
Spring Core 3.1.0 http://dist.springframework.org/release/IDE → Core / Spring IDE → Spring IDE Core 필수
UML2 Extension 4.0.2 http://download.eclipse.org/releases/indigo → Modeling → UML2 Extender SDK 필수
Subversive SVN Connector 1.0.0 http://download.eclipse.org/releases/indigo → Collaboration → Subversive SVN Team provider(Incubation) 설치
http://community.polarion.com/projects/subversive/download/eclipse/2.0/indigo-site/ → Subversive SVN Connectors → Subversive SVN Connectors 설치
필수
eGovFrame 2.5.0 표준프레임워크포탈 > 다운로드 > 개발환경 다운로드 URL에서 구현도구(Implementation Tool) 다운로드 후 설치
Help > Install New Software > Add클릭 > Archive선택하여 구현도구 파일 등록
필수
JUnit 4.8.1 Eclipse에 JUnit이 내장되어 있으므로 별도 설치 필요 없음 필수
PMD 3.2.6 https://pmd.sourceforge.net/eclipse → PMD for Eclipse 3 설치 선택
FindBugs 2.0.2 http://findbugs.cs.umd.edu/eclipse 선택
Properties Editor 6.0.0 http://propedit.sourceforge.jp/eclipse/updates/ → PropertiesEditor 설치 선택
  • Eclipse Helios(3.6) Packages 이용 시 설치가이드
소프트웨어버전자동설치/업데이트주소필수여부
Eclipse 3.6 http://www.eclipse.org/downloads/packages/release/helios/sr2 → Eclipse IDE for Java EE Developers 다운로드 필수
Maven(m2eclipse) 1.3.1
0.17.0
http://download.eclipse.org/m2e-wtp/releases/ → Maven Integration for Eclipse → m2e - Maven Integration for Eclipse / Maven Integration for WTP (Incubation) → m2e-wtp - Maven Integration for WTP (Incubation) 설치 필수
Spring Core 3.1.0 http://dist.springframework.org/release/IDE → Core / Spring IDE → Spring IDE Core 필수
UML2 Extension 4.0.2 http://download.eclipse.org/releases/helios → Modeling → UML2 Extender SDK 필수
Subversive SVN Connector 1.0.0 http://download.eclipse.org/releases/helios → Collaboration → Subversive SVN Team provider(Incubation) 설치
http://community.polarion.com/projects/subversive/download/eclipse/2.0/helios-site/ → Subversive SVN Connectors → Subversive SVN Connectors 설치
필수
eGovFrame 2.5.0 표준프레임워크포탈 > 다운로드 > 개발환경 다운로드 URL에서 구현도구(Implementation Tool) 다운로드 후 설치
Help > Install New Software > Add클릭 > Archive선택하여 구현도구 파일 등록
필수
JUnit 4.8.1 Eclipse에 JUnit이 내장되어 있으므로 별도 설치 필요 없음 필수
PMD 3.2.6 https://pmd.sourceforge.net/eclipse → PMD for Eclipse 3 설치 선택
FindBugs 2.0.2 http://findbugs.cs.umd.edu/eclipse 선택
Properties Editor 6.0.0 http://propedit.sourceforge.jp/eclipse/updates/ → PropertiesEditor 설치 선택
 
egovframework/dev2/install_guide.txt · 마지막 수정: 2018/01/05 13:31 작성자 com
 
이 위키의 내용은 다음의 라이센스에 따릅니다 :CC Attribution-Noncommercial-Share Alike 3.0 Unported
전자정부 표준프레임워크 라이센스(바로가기)

전자정부 표준프레임워크 활용의 안정성 보장을 위해 위험성을 지속적으로 모니터링하고 있으나, 오픈소스의 특성상 문제가 발생할 수 있습니다.
전자정부 표준프레임워크는 Apache 2.0 라이선스를 따르고 있는 오픈소스 프로그램입니다. Apache 2.0 라이선스에 따라 표준프레임워크를 활용하여 발생된 업무중단, 컴퓨터 고장 또는 오동작으로 인한 손해 등에 대해서 책임이 없습니다.
Recent changes RSS feed CC Attribution-Noncommercial-Share Alike 3.0 Unported Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki